[Top] [All Lists]

[na-user] renaming NA.EXE file problem

To: <>
Subject: [na-user] renaming NA.EXE file problem
From: David A. Pruett" < (David A. Pruett)
Date: Thu, 23 Jul 1998 00:21:14 -0400
Dan, W8CAR wrote:

>After seeing W4AN's idea about renaming different versions of NA I
>thought I'd give it a go.  I put NA version 10.17 into a directory
>with all the files and registered it. After registering I renamed
>NA.EXE to NA1017.EXE.  It does not work-I get the error msg-error
>63 occured in module na1017. I am a DOS dummy but I do know that
>is not good. I tried the same thing in a dummy directory -NATEST-
>with version 10.31 and still same result.

>Soooooo, what is this barely DOS literate dummy doing wrong ????

Hmmm...I tried Bill's idea with 10.31, renaming it to 1031.EXE and
it worked fine.

Error 63 means "Bad Record Number" which in this case probably means
the program is trying to read a file beyond its end.  Or, maybe its
trying to read a file which does not exist.  This is a Microsoft
error message, so I'm guessing here.

After further thought, there is probably a gotcha in Bill's approach.
Even after its registered, NA looks for itself to find the user name
which is shown on the signon screen.  It's looking for "NA.EXE"
explicitly, however it doesn't matter which one.  That is, as long as
you have one NA.EXE in the directory, NA will get the user name from
that file and all will be well.

So, the key is to rename all your NA versions but keep one around that
is named NA.EXE, even if its a duplicate copy of a renamed version.


Administrative requests:

<Prev in Thread] Current Thread [Next in Thread>