[Top] [All Lists]

[SD-User] FT-817nd and SD

To: <>
Subject: [SD-User] FT-817nd and SD
From: "Allen Wootton" <>
Date: Sat, 12 Nov 2011 14:12:24 -0800
List-post: <">>

I am trying to get my FT-817nd to operate properly with SD's rig control.  I 
would like to be able to have both rig control and keying operating from a 
netbook computer.  So far I have not been totally successful in achieving this, 
although I suspect the problems I am experiencing may be relatively easy to 

I  first began with a Yaesu CT-62 cable connected between the serial port of my 
old PC (running XP) and my FT-817.  I found that if the FT-817's narrow filter 
is turned on when switching the rig between SSB and CW, the SD screen does not 
switch to CW.  As soon as the narrow 
filter is switched off (on the rig) SD changes to CW and SD follows the changes 
CW-->SSB or vice versa without problem.  SD doesn't change the rig between SSB 
and CW, i.e. on typing SSB into the SD entry there is no change.  Also, I 
haven't been able to achieve direct frequency entry from SD to the rig.  The 
rig's frequency is read out on the SD screen, however.

Since I want to use SD running on a netbook computer to control my FT-817, I 
constructed a USB to TTL interface cable that uses an FTDI RS-232 to TTL cable. 
 This cable gives the same results as the Yaesu CT-62.  My homemade cable also 
provides an RTS line which I hope to use for keying the FT-817.  At first I had 
trouble getting the USB virtual com port shared between rig control and keying. 
 I found that the SHARECOM command fixed that.  In spite of com port sharing, 
however, there is still no keying of the RTS line of the USB to TLL converter.  
RTS remains high continuously.  The TUNE command brings RTS low as does 
keyboard keying and the memory keys (but no 
characters are sent from memory or keyboard - just a continual low).  

I checked through the SD manual and saw that deleting the init file and 
restarting the computer and SD might solve these problems so I tried this.  The 
result was some new unexpected behaviours - for exmple, now an SSB to CW change 
on the radio didn't show up on the SD screen.  I went back to the original init 

I don't think that the problem I'm experiencing is caused by my homemade USB to 
TTL cable because I tried using this cable with Ham Radio Deluxe and it works 
perfectly and provides exactly the same operation as the Yaesu CT-62 cable. 

For most of my testing I used my old PC running Windows XP, but I also tried it 
on my new netbook computer (Windows 7 starter ed.) and there I get the same 
results. All of these findings suggest to me that there may just be some minor 
configuration error(s) in my settings.  I would certainly appreciate any 
suggestions as to what I should try next so as to make the rig control and 
keying operate correctly. 


Allen, VE7BQO

SD-User mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [SD-User] FT-817nd and SD, Allen Wootton <=