[Top] [All Lists]

re my paragon 585

To: <tentec@contesting.com>
Subject: re my paragon 585
From: promedia@itnet.com.pl (Promedia sp. z o.o. (Ltd.))
Date: Tue, 18 Feb 1997 12:17:54 +-100
Dear Scott,

thanks for the fax you sent me yesterday.
Foolish or not, it was the only way (last resource) I grabbed
to reach you.

Find below the text I have just received, which might be of interest to you.
I completely and totally agree with it. Besides, I love the rig and I want to
keep it despite some friends of mine who do not really understand such
a point of view.

I must say I expected more choosing paragon 585, that's why I am bit 
at the way and quality it has been produced. 
Hopefully, I will repair it somehow...

Yours  (always thin),


quote the text:

Hi Alec;

Sorry to read about your problems with Paragon. You maybe are interested 
in how my relation ship with my Paragon started years ago.

I also after lots of thinking decided to buy a Paragon. Mostly because
it is an American rig and I have always admired Drake and Collins 
equipment. OK what happened next. I got my Paragon, 961 power,
additional 500Hz CW filter and RS-232 Board. I unboxed the rig and 
removed bottom cover and installed CW filter, it was easy and went fine.
Next step was take top cover off and install RS-232 board. I went fine 
until it was time to put top cover back speaker screws were too long
and top cover didn't fit at all. OK, we had and have here importer for 
Ten-Tec here in Finland and through that company I got a new top cover.
I removed RS-232 board until I got a new top cover. Then I installed an
alchaline battery as a backup battery (recomended in manual) I turned 
power on and I started working. After few hours I heard loud BANG from
my schack, went there and found Paragon acting oddly. Top cover off and
what a mess I had there, that battery has exploded (never install
battery for backup always use NiCD). I had to clean top part of rig and
it was a big job and I was considering to send my rig back and
demand my money back, but I didn't.
OK after a week or two I got a new top cover, had purcased NiCD for
backup and I installed RS-232 board again. Top cover fits perfectly
and all went fine, I was on the air again. All was fine until I put power 
off from rig. With my RS-232 board it couldn't keep memory contents.
Oh my God why me why all this trouble for me for a new rig. OK I returned 
that RS-232 board and got a new. 

After that all trouble all worked fine for couple of years, then I got
that major loop problem you described. I also resoldered major loop, first
time I were not enough careful and few spots remained unsoldered, and
I had to do it again. Problem went away.

Why I write this all to you? Because still due big problems I am that
opinion that Paragon is one of the best rig I have worked with, even
the best. I have tried OMNI V, DELTA II, Paragon II, FT-990, JST-135
and for me Paragon fits best. Even I have troubles. Only poor thing
in Paragon has been poor quality assurance and not so well tuned
soldering machines. The idea is superb. I hope that we can share
our experiences and faults as Paragon owners, what you say? By the
way if you are capable to do some computer programming I like to 
send you Paragon RS-232 command set and old Ten-Tec software to
control Paragon. There is also replacement for Paragon internal
software from Giehl electronics in U.S.A, I have used it now for
3 years and I like it.

Best regards from

Ari / OH3HZ
e-mail oh3hz@sci.fi or arleh@wmdata.com

FAQ on WWW:               http://www.contesting.com/TenTecFAQ.html
Submissions:              tentec@contesting.com
Administrative requests:  tentec-REQUEST@contesting.com
Problems:                 w9tw@contesting.com
Sponsored by:             Akorn Access, Inc & N4VJ / K4AAA

<Prev in Thread] Current Thread [Next in Thread>
  • re my paragon 585, Promedia sp. z o.o. (Ltd.) <=