[Top] [All Lists]

[TenTec] Corsair II problem

To: <tentec@contesting.com>
Subject: [TenTec] Corsair II problem
From: k6sdw@hotmail.com (Eddy Avila)
Date: Sat, 02 Feb 2002 18:05:50 +0000
Hi Lee....I too had power output problems when I bought a used Corsair II 
off of eBay (of course, advertised as working perfectly -- but then that's 
another eBay story!)....finally discovered the problem: Several components 
in the low-level RF driver stages had never been soldered to the circuit 
board....I mean, never!!!! I guess I had the Monday-morning built rig! 
Anyway, soldered driver transistors and other components to board now have 
tons of drive and output!!

By-the-way, I did everything you have already done but somehow kept 
overlooking the problem on the driver board.......Old age, I guess...HI!

Just my experience........you've indicated you already checked that board so 
what I would do now is make an RF sniffing tool (oscilloscope would be great 
here!) and start following the signal from the beginning to end....good 
luck. 73..../k6sdw

>From: "B. Lee Cornwell" <leec@ptd.net>

>Good Morning to all - I've been having some difficulty with an intermittent
>power output problem on my Corsair II. At times the power output (on SSB
>only) drops to half or less of normal output, as seen on the scope and lack
>of ALC led lighting. CW or tune position is full output with no problems.
>Advancing the drive control seems to have little effect, other than to
>flat-top when full out put comes back.
>I have removed EVERY connection plug and cleaned with De-oxit and Q-tip and
>re-seated. I have removed low lever driver board and re-soldered every
>connection. What next ?? Any ideas where to look next ? I suspect a problem
>on the audio board, but because of it's intermittent nature it is very
>difficult to "pin down". Thanks in advance - Lee K2BLC

MSN Photos is the easiest way to share and print your photos: 

<Prev in Thread] Current Thread [Next in Thread>