[Top] [All Lists]

Re: [TenTec] Lousy eHam review

To: Discussion of Ten-Tec Equipment <tentec@contesting.com>
Subject: Re: [TenTec] Lousy eHam review
From: jmalloy <jmalloy@stny.rr.com>
Reply-to: Discussion of Ten-Tec Equipment <tentec@contesting.com>
Date: Tue, 04 Jul 2006 00:47:03 -0400
List-post: <mailto:tentec@contesting.com>
Toby Pennington wrote:
> I was just forwarded an email from the poster of the Lousy eHam Review
> describing his experience with the Jupiter and Ten Tec.  He seemed to have
> some very real issues with the Jupiter including RF problems which could not
> be resolved.  His ground system was installed under his house when it was
> built,  and all his other rigs worked very well and he has quite a few well
> known rigs.  Other issues involved how he was handled by Ten Tec personel.
> It seems like someone may have dropped the ball at TT to some extent.
> I have had really bad rf problems before and it can drive you nutty trying
> to fix it.  The guy was fed up and it shows in his post.   Happy July 4th
> all!
I don't know what the problem is (I have my thoughts about it, though) 
with some people and the Jupiter, but I had one for a few years before 
trading it in on the Orion and I thought it was a pretty good radio.  
Transmit audio was very nicely adjustable, receive audio was plentiful, 
and the software was field updatable and stable.  No RF or grounding 
problems here and I used it on all bands, modes and power levels with 
nary a problem (and believe me, I didn't have a very advanced antenna 
system at the time (still have a basic, but better one) or grounding 
system -- a G5RV and a pipe 8' in the ground!).  I'm not a DX'er but 
worked numerous countries on all the upper bands (okay, maybe the 
sunspots had something to do with it!).  As far as I was concerned, it 
was and, as far as I know, a great radio -- for its price point. 

Maybe some people expect more.


Joe, W2RBA

TenTec mailing list

<Prev in Thread] Current Thread [Next in Thread>