[Top] [All Lists]

[TenTec] Corsair Model 560 freq display fixed

To: TenTec@contesting.com
Subject: [TenTec] Corsair Model 560 freq display fixed
From: "Keith Johnson" <kj.kb8fe@gmail.com>
Reply-to: Discussion of Ten-Tec Equipment <tentec@contesting.com>
Date: Fri, 14 Dec 2007 22:54:37 -0500
List-post: <mailto:tentec@contesting.com>
My Corsair Model 560 frequency display began displaying random numbers.
After cleaning all ground contacts, cleaning all cable contacts, learning
about most of the chips in the frequency counter/display, probing with the
scope and googling about this problem I was able to narrow it down to the
.47 uf 50 volt polarized electrolytic capacitor (C13) on the time base
board.  An inexpensive component to say the least.  Now my beloved Corsair
is again displaying a stable frequency and overall working fine.  I have had
the rig probably about 15 or 20 years with no problems other than a dirty
connector contact located on the back of the rig.

Someone on this list, in a previous post, suggested that all related
electrolytic capacitors be replaced on any troublesome board (I think 'as a
first step').  In this case the fellow was 'spot on' and I want to thank him
for posting that suggestion.  Also, I hope those that have a similar problem
with their Corsair Model 560 read this post and use it to possibly solve
their problem.  I learned quite a bit from my troubleshooting and solving
this problem was a highlight of my hamming activity.

Keith  /   KB8FE in Ohio
TenTec mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [TenTec] Corsair Model 560 freq display fixed, Keith Johnson <=