[Top] [All Lists]

[TenTec] ESD - Static Discharge revisited OMNI VII

To: Ten Tech Reflector <tentec@contesting.com>
Subject: [TenTec] ESD - Static Discharge revisited OMNI VII
From: Bill Mellema <mellema@qis.net>
Reply-to: Discussion of Ten-Tec Equipment <tentec@contesting.com>
Date: Wed, 23 Jul 2008 19:40:06 -0400
List-post: <tentec@contesting.com">mailto:tentec@contesting.com>
I now have a new OMNI VII which I really like ..however I noticed 
again that walking across my carpeted office and touching the mike 
connector caused the receiver to quit. If I recycle the power it is 
fine again. I had this problem with another OMNI VII I owned and 
never could get it straightened out. I am running a ASTRON 55 AMP 
power supply with the chassis ground going back to the OMNIVII's 
chassis ground (I did this after the ESD problem was first noticed). 
I have since measured the resistance from the OMNI VII's chassis 
ground and the mike connector and the 1/4 inch CW and Headphone 
jacks. They are all above ground which I think is the problem. Heck 
you can ground the radio but what does it do if the front panel jacks 
aren't grounded?

If anyone has a remedy for this other than touching something to 
discharge before using the OMNI VII I would appreciate hearing about 
it. I ran an ICOM756PRO & IC756PROII which are also DSP radios and 
never had this issue. I understand the OMNI VII is more computer than 
radio but I feel it has to stand up to normal radio shack conditions 
not to mention Field Day. It's a great rig but I have to come up with 
a satisfactory solutions before this Winter when the ESD is much more severe.


Bill N3WM

Bill Mellema
B&J Communications Inc.
2230 Ridgemont Drive
Finksburg, Maryland 21048
Fax 410-861-8605
Cell 410-790-6072

TenTec mailing list

<Prev in Thread] Current Thread [Next in Thread>