[Top] [All Lists]

Re: [TenTec] delta II display problem - anyone?

To: tentec@contesting.com
Subject: Re: [TenTec] delta II display problem - anyone?
From: "Dr. Gerald N. Johnson" <geraldj@weather.net>
Reply-to: geraldj@weather.net, Discussion of Ten-Tec Equipment <tentec@contesting.com>
Date: Fri, 02 Jul 2010 04:50:48 -0500
List-post: <tentec@contesting.com">mailto:tentec@contesting.com>
Board ground failures at the board mounting screws can give odd results. 
Since the displays usually are multiplexed, dried up power supply (on 
the display logic board) electrolytics can give odd symptoms too. The 
first two digits probably are driven by the bandswitch with the rest 
driven by the counter which may be a vintage microprocessor, like a 
MC6805. For longer life replace those miniature electrolytics with the 
highest temperature rated and lowest ESR caps you can buy from Mouser. 
www.mouser.com. The binary to 7 segment display driver could be gone, 
but check the grounds first and if that IC is in a socket, clean its 
pins with DeoxIT. Probably just lifting it partly and reseating it will 
have an effect if its dirty socket and IC pins.

73, Jerry, K0CQ

On 7/2/2010 12:20 AM, john ferro wrote:
> Hi, I recently picked up a Ten Tec Delta II 536 from a local ham. I got a 
> good deal on it, but i bought it knowing there were some problems. A loose 
> VFO knob, lcd backlight is out and the most serious, erroneous frequency 
> readings. The radio receives great and has a wonderful quiet Ten Tec receive. 
> I have not tried transmit yet, but was told it puts out full power.
> The main problem is the frequency display is cuckoo. 5's can have an extra 
> segment - 8's can look like two lines or 6's - the lsb and usb indicators are 
> on at the same time, there's a segment missing on the swr indicator etc etc., 
> just crazy readings that make it hard to know where you are.
> interestingly enough the first two digits in the freq. display are fine, so i 
> at least know what band i'm on. It seems the display driver might be bad or 
> maybe the encoder. i figure no better place to post this message than here. 
> any help would be appreciated.
> 73, john
> _________________________________________________________________
> Hotmail has tools for the New Busy. Search, chat and e-mail from your inbox.
> http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_1
> _______________________________________________
> TenTec mailing list
> TenTec@contesting.com
> http://lists.contesting.com/mailman/listinfo/tentec
TenTec mailing list

<Prev in Thread] Current Thread [Next in Thread>