[Top] [All Lists]

Re: [TenTec] Omni 6 Logic Board Failure

To: tentec@contesting.com
Subject: Re: [TenTec] Omni 6 Logic Board Failure
From: NL7VL <neal.laugman@gmail.com>
Reply-to: Discussion of Ten-Tec Equipment <tentec@contesting.com>
Date: Mon, 17 Jan 2011 18:55:27 -0600
List-post: <tentec@contesting.com">mailto:tentec@contesting.com>
My experience in field troubleshooting in the days of discrete
components and early TTL/CMOS was that 90% of problems always had a
relationship to a connection - be it an IC socket, bad solder joint, or
faulty multi-pin connection on the module level. I would always assume
at the beginning that the semiconductors are OK except when the board

But with custom controller chips and the like that are flourishing
these days, I don't have the experience to comment on their reliability
one way or another. As I said earlier today, I'll talk to TT tomorrow
and try to get some information - and hopefully a TT employee might even
post a response to some of this.

 Neal, NL7VL

On Mon, 17 Jan 2011 16:05:29 -0600
"Dr. Gerald N. Johnson" <geraldj@weather.net> wrote:

>Given a working Omni VI to compare too (and borrow some parts from) it 
>appears to be fairly practical to keep working though my first attack 
>would be to connect around the DSP to minimize the work required to 
>recover from a problem. But FIRST I'd replace the battery and do a
>major reset. It certainly could be a complex puzzle to work out, but
>things like the battery, cleaning the contacts on the EPROM socket
>(and any other sockets on the control board) along with spares for the
>other plug in chips would be in order. But somewhere in that process
>I'd replace the electrolytics on the board remembering how the Corsair
>and Corsair II display boards mess up when the electrolytics go bad.
>Up to this point these are relatively low tech things that can mess up
>a computer based control board. After that it gets messy but those low
>tech things are common.
>I recall that for some radios with sockets for EPROMs, the approved 
>factory fix was to remove the socket and solder the chips to the board 
>because they had chosen a poor quality socket.
>73, Jerry, K0CQ
>On 1/17/2011 11:53 AM, NL7VL wrote:
>> Don,
>>> This thread makes me nervous as hell.
>> Apparently you aren't the only one ...
>TenTec mailing list


TenTec mailing list

<Prev in Thread] Current Thread [Next in Thread>