[Top] [All Lists]

Re: [TenTec] Omni VI S-meter

To: tentec@contesting.com
Subject: Re: [TenTec] Omni VI S-meter
From: "Dr. Gerald N. Johnson" <geraldj@weather.net>
Reply-to: geraldj@weather.net, Discussion of Ten-Tec Equipment <tentec@contesting.com>
Date: Wed, 26 Jan 2011 01:11:42 -0600
List-post: <tentec@contesting.com">mailto:tentec@contesting.com>
Chasing the schematics, I find the meter is driven by the S-meter 
circuits for SSB and FM through diodes for all positions of the meter 
switch. The difference is that its also driven by a op amp on the 9 MHz 
Mixer/IF board 81594 with a series cal pot and a diode. There's also a 
shunt capacitor. If the cal pot got turned way up it might take over, if 
the op amp failed or a board ground failed, or something failed in the 
ALC FWD detector circuit to push lots of voltage to the op amp (U1A) 
that would drive the meter full scale and beyond all the time. I didn't 
chase down the FWD power detector circuit, but I think its also used for 
ALC and I recall reports of Tentecs sometimes losing diodes in that 
circuit from nearby lightning while connected to an antenna.

73, Jerry, K0CQ

On 1/25/2011 11:22 PM, Hamdriver66@aol.com wrote:
> I have an Omni VI, upgrade one with all TenTec filters installed. The
> S-meter has just developed a problem that I would like to ask for input to try
> to solve.
> The meter works as designed in all meter switch positions except for FWD,
> where the needle pegs out at top of scale in receive or transmit, and stays
> at  full scale all the time.
> I have reseated all the connectors and circuit boards that I can reach
> without disassembling the whole radio and have used DeOxit on all switches and
> controls.
> Has anyone seen this condition and are there any ideas as to cause?
> Thanks in advance for any help.
> Mike  K4KJC
TenTec mailing list

<Prev in Thread] Current Thread [Next in Thread>