[Top] [All Lists]

Re: [TenTec] Argosy 525

To: John <jh.graves@verizon.net>
Subject: Re: [TenTec] Argosy 525
From: Mike Bryce <prosolar@sssnet.com>
Reply-to: Discussion of Ten-Tec Equipment <tentec@contesting.com>
Date: Thu, 16 Feb 2012 12:08:56 -0500
List-post: <tentec@contesting.com">mailto:tentec@contesting.com>
Oh yeah!

I still have my argosy II. I think ( my opinion) that this radio was one of the 
better designs form ten tec. 

It had enough bang to work the world. Was battery friendly and when condx were 
right flip a switch and go QRP. 30 meters was a real plus at the time that 
radio was made. 

As for your distortion. Try the simple things first. Deoxit the power plug were 
it goes into the radio. Now flip the qrp/qrp switch back and forth a few times, 
cleaning the contacts. 

Pop the top and loosen each screw on just one pcb at a time no more than half a 
turn. When the assembly is loose press down in the pcb and gently wiggle it. 
Tighten the hardware. 

Ten tec used the mounting hardware to supply grounding in some of the pcbs. 
Wiggling the boards breaks away any of the oxide formed between the solder and 
aluminum spacers. 

On the top of the radio's chassis the pcb toward the PA is suspect. It contains 
a lot of the functions for ssb generation and the low level RF driver. 

I am doing this from memory as I am at work right now. 

You want to make sure the mounting hardware is tight. 

Try these simple things first. 

Mike wb8vge

Sent from my iPhone

On Feb 16, 2012, at 11:49 AM, John <jh.graves@verizon.net> wrote:

> Mike,
> Speaking of dinosaurs, while my Jupiter is in the shop, I am using an Argosy 
> 525 (the original.) Have you had any experience with these?  One of the 
> others in my local net is reporting some kind of oscillation on my voice and 
> I am trying to find out where to look for this one.  I have already backed 
> off the drive to the point where I am no longer getting the rated max (50 W) 
> on my signal.   I am using a Shure 444 that works fine on my Jupiter.  So I 
> am a bit puzzled.
> -- 
> John / WA1JG
TenTec mailing list

<Prev in Thread] Current Thread [Next in Thread>