[Top] [All Lists]

[TowerTalk] Loss in Alpha Delta Switches ?

To: <>
Subject: [TowerTalk] Loss in Alpha Delta Switches ?
From: (Jim Reid)
Date: Mon, 21 Jan 2002 18:25:17 -1000

> You forgot to mention that you took out the Alpha Delta 
> switch with your Henry 8K amplifier. 

Of course,  Pat,  you are assuming I was exceeding the
legal limits of output power.  And maybe I was,  for the
instant that this occurred.  It was just days after I rcv'd
the 8K from Henry,  some three years ago.  And I was
learning the "ropes" of use.  However,  the fact remains,
that the internal construction of the switch still seems odd!

Yes,  it did occur when I was doing a "tune up"; and the output
power from my FT-1000D may have been too high.  And, yes 
the RF sense PC board was "blown" in the RF apps 
swr/power meter.  Rather incriminating evidenced about
over the power limit.  

But,  my question was:  "Has anyone else had a problem with
Alpha-Delta switches after the linear?".  And,  I have rcv'd
several replies in the affirmative.

But what I really wanted to know was,  in the spirit of the
thread about connector loss,  was there similar experience/
knowledge about loss with-in our the common RF switches
so many of us use every day.

Anyhow,  Pat has kept me honest,  hi.  And,  ever since,  I have
been VERY careful about output power using this 8K!  I bought
it for long,  cool life of the amp with no problem using higher
duty cycle modes.

73,  Jim  KH7M

Where do you get ICE bandpass filters & beverage matching boxes?  The
same place that pays for the hosting of this list:  The eHam Store.
Order online at

FAQ on WWW:     
Administrative requests:

<Prev in Thread] Current Thread [Next in Thread>