[Top] [All Lists]

Re: [TowerTalk] Copper Strapping Clamps

To: "'towertalk reflector'" <>
Subject: Re: [TowerTalk] Copper Strapping Clamps
From: "James Chaggaris" <>
Date: Mon, 24 Jul 2006 10:42:57 -0500
List-post: <>


That's how they are suppose to be configured.
But I too had problems using the Polyphaser clamps with my 5/8" ground rods.
I had to add about 4 or 5 copper strip shims to get a good firm connection
to the ground rod.


Jim N9WW

James E. Chaggaris
PowerOne Corp.
1020 Cedar Ave.
Suite 110
St. Charles, IL 60174
Phn:(630) 443-6500
Fax:(630) 443-6505

-----Original Message-----
[] On Behalf Of Alan NV8A
Sent: Monday, July 24, 2006 10:30 AM
To: towertalk reflector
Subject: Re: [TowerTalk] Copper Strapping Clamps

Maybe I have misunderstood how the Polyphaser clamps are intended to be
used, but if I pass the copper strip between the bolts and around one side
of the nominally 5/8" ground rod (actually approx. 1/32" shy), everything
seems to clamp together just fine. IOW, the clamp is clamping the copper
strap firmly *against* the ground rod

Alan NV8A

On 07/24/06 08:54 am Brad Nowak wrote:

> I too found the strapping clamps too large for standard 5/8 in ground
> I did find that they work perfectly on 3/4 in ground rods usually only 
> available at industrial electric suppliers (only in 10' lengths I 
> might add).  I didn't like using the shims of copper as it was a real 
> PITA trying to get everything aligned to tighten securely.


TowerTalk mailing list


TowerTalk mailing list

<Prev in Thread] Current Thread [Next in Thread>