[Top] [All Lists]

Re: [TowerTalk] SteppIR problem-update from the front lines

To: "'K4SAV'" <>
Subject: Re: [TowerTalk] SteppIR problem-update from the front lines
From: "James C. Garland" <>
Date: Sun, 17 Jun 2007 21:30:04 -0600
List-post: <>
I think Jerry is exactly right in his suggestions. Evidently, some sort of
current transient is shutting down the power supply.  A 12V negative spike
on a +33VDC power supply at tuning startup is very odd indeed. Sounds like
an inductive kick of some sort. 

But there's really no way to diagnose the problem without a circuit diagram.
This is definitely an issue for the company to solve.

I understand the desire for companies to keep their designs close to the
chest, but the Steppir controller circuitry doesn't seem particularly
sophisticated to me. By not publishing the schenatic diagram, or any of the
engineering test results, the company therefore has a major responsibility
to stay on top of service complaints. Customers can't fix or diagnose
problems without the diagrams, so they're really stuck if the company
doesn't come to their aid. There are a large number of sophisticated and
experienced hams who would be will to lend a hand in cases like this, so it
seems to me that SteppIR is losing out on a valuable resource by keeping
their designs secret.

Jim W8ZR

-----Original Message-----
[] On Behalf Of K4SAV
Sent: Sunday, June 17, 2007 9:03 PM
Subject: Re: [TowerTalk] SteppIR problem-update from the front lines

Doing engineering analysis from where I am sitting is very difficult, 
and you are down to that point.  The part substitution method hasn't 
worked and there is only one part left that hasn't been substituted. 
(And I doubt that will solve the problem either.) Plus you didn't give 
us many details of your measurements other than you made them and they 
were OK. So everyone is just taking wild guesses.  (I thought the water 
in the cable guess was pretty good.)  Here are some questions.  The 
answers to these would help a lot.

1.  When you ohmed the lines to the motors what were the readings? Were 
they all very close to the same?

2. Did you check every line for resistance between each line and every 
other line and ground?  Were they all open except for the mate for the 
one being tested?

3. Is the DC ground for the power supply tied to station ground?  Did 
you measure it?
  Note: This can be a difficult to measure, because there may be some 
small voltage on it.
 (This DC ground should not be connected to the tower ground at the 

 If it is connected, remove the serial cable to the computer and 
re-measure it.  If it is still connected, this may be a problem.

4.  Are there any other devices connected to this cable such as 
transient suppressors or a tuning relay?



TowerTalk mailing list

<Prev in Thread] Current Thread [Next in Thread>