[Top] [All Lists]

Re: [TowerTalk] SteppIR problem-update from the front lines

Subject: Re: [TowerTalk] SteppIR problem-update from the front lines
From: K4SAV <>
Date: Mon, 18 Jun 2007 18:32:52 -0500
List-post: <>
I don't think I would take the antenna down unless you are at the point 
of shipping the whole thing back to FM for a refund.  I can't think of 
any possible problem with the antenna that could cause this, that hasn't 
already been eliminated.

A motor winding with a short or any relatively low impedance to ground 
was eliminated with the ohmmeter measurements.  A motor short, or 
partial short, should not be a problem because the motors are current 
driven.  Excessive friction, tape jams or anything like that should not 
cause the motor to draw more current for the same reason.

One concern I had was that maybe the DC ground was connected at the 
tower and a ground loop was causing a problem.  After looking at the 
cable info in the manual, I see there is no ground wire in the cable, so 
that is not possible.  There is a shield wire and that should be 
connected to tower ground.

My best guess as to the cause of this is that you are right up to the 
limit of what the system can do. The long cable length combined with the 
excessive current pulse presented to the power supply by the controller 
is causing the supply to drop too low.  Remember the power supply 
voltage transient is present whether the cable is connected to the 
antenna or not, so a large part of this transient problem is not due to 
load, but due to some "feature" in the controller.

I opened my power supply to see if I could determine how much 
capacitance was on the output of this supply.  I wanted to know if the 
supply was capable of handling a 6 amp transient without dropping the 
voltage.  It is a switch-mode supply with a 150 uf 400 V cap on the 
primary side of the regulator, and there are 3 - 230 uf 63 V caps on the 
output side.  I am guessing these are all in parallel since I can't see 
the bottom of the circuit board without a lot of disassembly.  So with 
690 uf of capacitance, and a 6 amp current pulse, the voltage will drop 
8.7 volts in 1 ms.  So the cap is not capable of supplying the load 
current for the transient and the regulator must do it.  Since the 
supply is only rated for 2 amps, it may be that the regulator is going 
into current limit.  I can't be sure of that without the schematic, but 
I think that is a good guess.

A band-aid fix might be to add large cap on the power supply line.  It 
would probably take about 5000 uf at 40 volts.  Another possibility is a 
different supply capable of more current.  The real fix would require a 
controller mod.  Remember this is only my best guess based on limited 

I shouldn't take FM more than a couple of hours to verify this 
information.  (Of course, then there will be a big pause to determine 
what to do about it.)

Jerry, K4SAV

Dick Green wrote:

>I'd like to know the answers to Jerry's questions #1 and #2 below, too.
>Also, what make and model DVM was used to make the measurements? Was the
>resistance of the leads checked and subtracted from the readings?
>As I see it, there are three possibilities:
>1. The SteppIR controller doesn't work reliably with cables greater than a
>certain length. If I remember correctly, Bill has a total of about 520 feet
>of cable between the controller and the antenna (440' in the conduit and 80'
>on the tower.) It would seem a simple matter for SteppIR to run a series of
>tests with a 4-el and lengths of cable ranging from 400-600 feet. I wouldn't
>rely on anecdotal evidence from customers.
>2. One of the motors has a borderline defect, such that the combined motor
>load doesn't overload the controller with shorter lengths of cable, but
>somehow the load is increased beyond the capacity of the power supply by the
>greater capacitance and/or resistance of the longer cable.
>3. There is a marginal defect in the cable or wiring on the tower. Not too
>long ago, I moved my SteppIR from a temporary cable to a permanent buried
>cable (yeah, I know it's not rated for that.) I stupidly forgot to power
>down the controller and unplug the cable before making the switch. Luckily,
>I didn't damage the controller. However, when I got to the shack, I found
>that the controller was periodically tuning the antenna -- I was alerted by
>the N8LP Tuning Relay cycling on and off on a regular basis. I didn't
>measure the cycle time, but it was under a minute -- might have been a few
>seconds. Anyway, I powered down the controller and checked the cable from
>the shack. Sure enough, one of the leads was shorted to ground. The
>resistance was not zero -- it was a few ohms. I checked wiring at one of the
>suppressor panels and found that a tiny tendril of shield braid was touching
>one of the suppressor terminals. Snipping that piece of braid fixed the
>problem. My point is that it doesn't take much of a short to confuse the
>controller and, depending on the type of DVM you have, and how it does
>continuity tests, a partial short may go undetected. Further, it's
>particularly easy for tendrils of shield braid to touch the motor wire screw
>terminals at the antenna end. That's one reason I switched to telco
>waterproof connectors. I'm not saying this is the exact problem Bill has. I
>would expect something like that to show up with a long or short cable. But
>a marginal condition, where a motor wire is only partly shorted to ground or
>another motor wire, might be interacting with the longer cable. A good,
>sensitive DVM should be able to reveal a problem like that.
>Bill, at this point you can reasonably conclude that the only thing left to
>do is take the antenna down, especially if you are seriously considering
>another type of antenna. But there's one more test I would do: Take the end
>of the spare 440' cable up to the SteppIR and wire it in place of the run
>going up the tower. Connect the controller at the other end of the 440'
>cable. If it works, there are three possibilities: 1) The 80' cable run up
>the tower has a marginal defect, 2) There was a marginal wiring problem with
>the 80' cable run at the antenna, 3) 440' is below the threshold for a 4-el
>SteppIR cable (again, SteppIR should be able to answer the cable length
>If the 440' run works, I'd cut it at the bottom of the tower and wire it to
>the cable in the conduit.
>If the 440' run doesn't work, it's time to take the antenna down. If it was
>me, I'd ask SteppIR for one spare passive EHU and one spare driven EHU, and
>substitute to see if there's a marginal motor problem. If that doesn't work,
>I'd pack it all up in a big box and ship it back to SteppIR for a refund.
>73, Dick WC1M
>>-----Original Message-----
>>From: K4SAV []
>>Sent: Sunday, June 17, 2007 11:03 PM
>>Subject: Re: [TowerTalk] SteppIR problem-update from the front lines
>>Doing engineering analysis from where I am sitting is very difficult,
>>and you are down to that point.  The part substitution method hasn't
>>worked and there is only one part left that hasn't been substituted.
>>(And I doubt that will solve the problem either.) Plus you didn't give
>>us many details of your measurements other than you made them and they
>>were OK. So everyone is just taking wild guesses.  (I thought the water
>>in the cable guess was pretty good.)  Here are some questions.  The
>>answers to these would help a lot.
>>1.  When you ohmed the lines to the motors what were the readings? Were
>>they all very close to the same?
>>2. Did you check every line for resistance between each line and every
>>other line and ground?  Were they all open except for the mate for the
>>one being tested?
>>3. Is the DC ground for the power supply tied to station ground?  Did
>>you measure it?
>>  Note: This can be a difficult to measure, because there may be some
>>small voltage on it.
>> (This DC ground should not be connected to the tower ground at the
>> If it is connected, remove the serial cable to the computer and
>>re-measure it.  If it is still connected, this may be a problem.
>>4.  Are there any other devices connected to this cable such as
>>transient suppressors or a tuning relay?
>>I have a 4 element SteppIR with 250 feet of cable.  I just looked at
>>output of my power supply with a scope to see if I could learn
>>anything.  Seems this is the only way since SteppIR doesn't publish
>>their schematics. I was a bit surprised at what I saw.  The supply
>>output was close to the nominal 33 volts, but when the antenna was
>>there was a 12 volt negative going spike on the DC power supply line.
>>It then ramped back up the nominal voltage in 30 ms.  This did not
>>continue as the antenna was tuning, but occurred only once at the start
>>of tuning.  It also occurred each time the antenna was moved one
>>frequency step.  I also measured the current spike that was causing
>>voltage spike.  It was 6 amps.
>>If the cable to the antenna is disconnected, this 12 volt spike is
>>present on the power supply, but it only takes 1 ms to recover to
>>nominal voltage.
>>The cause of this spike or its effect is unknown since I don't have a
>>schematic, but it doesn't look like something that is very good, and it
>>is sure going to complicate the problem of keeping the controller from
>>shutting down when heavily loaded. I could take a guess at the cause of
>>this, but I won't because it would only be a guess.  This kind of
>>engineering stuff belongs back at the factory.
>>I also tested the supply by itself to see if it had good regulation.  I
>>did transient load tests up to 2 amps which is the rated current for
>>supply.  The output showed no sign of dropping voltage. I did not test
>>to see what it would do with a 6 amp transient.
>>The resolution of this problem, is it is a problem, belongs at the
>>factory.  A beefier power supply might hold the voltage up better,
>>however since the controller can cause this spike without the cable
>>connected, the source of the problem is probably in the controller.
>>I hope FM reads this message because I would like to suggest that they
>>set up a test fixture and measure the acceptable limit of cable.
>>someone report that they have one working that has 500 feet of cable
>>hardly qualifies as engineering data.  The max limit should be measured
>>and the reason for failure above that limit should be determined.  If
>>they haven't done the system analysis for the cable system, that should
>>be done also.
>>Jerry, K4SAV


TowerTalk mailing list

<Prev in Thread] Current Thread [Next in Thread>