[Top] [All Lists]

Re: [TowerTalk] Ground Clamps

To: towertalk reflector <>, Alan NV8A <>
Subject: Re: [TowerTalk] Ground Clamps
From: Mark Spencer <>
Date: Mon, 7 Jul 2008 16:19:24 -0700 (PDT)
List-post: <">>
Interesting thread which brings to mind a question:
The last time I looked at the bronze clamps (purchased at Home depot) 
connecting my copper ground wire to my roof mounted galvanized steel antenna 
masts I noticed some minor discolouration and a white powdered material at the 
junctions between the copper wire and the bronze clamp and the bronze clamp and 
the galvanized steel mast.   The copper is not in direct contact with the 
galvanized steel.
I have put a clamp on ammeter on the ground wire and can't measure any current 
flowing thru the ground wire (I did not expect to see any, but I thought that 
if current was flowing thru the ground wire this might have explained what I 
was seeing.   As the ground wire is ultimatley tied into the electrical service 
ground and the some of the masts are connected via antenna mounts to coax 
shields that run back to radios in the shack I felt there was small possibility 
of current flowing thru the ground system.)
Given that the masts are roof mounted they are probably more exposed to the 
elements than clamps at ground level on a typical tower would be.  I'm not 
really worried about this but I did not expect to see visible corrision (if 
that is in fact what I am seeing ?) when using bronze clamps.    The next time 
I'm visiting comerical radio sites thru work I'll take a closer look at the 
ground clamps and see if notice any thing similar but I don't recall seeing 
this before.
Any comments would be welcome.

--- On Mon, 7/7/08, Alan NV8A <> wrote:

From: Alan NV8A <>
Subject: Re: [TowerTalk] Ground Clamps
To: "towertalk reflector" <>
Cc: "Roy & Peggy Bonvillian" <>
Received: Monday, July 7, 2008, 6:55 PM

On 07/07/08 05:37 pm Roy & Peggy Bonvillian wrote:

> I have just set my base for my 55G and have my UFER ground wires that need

> to be connected to the legs of the tower. I have 3 #4 gauge wire coming
> of the cement near each leg. My question is where do I fine the proper 
> clamps to connect the bare copper wire to the 3 legs and also have a place

> to tie in the wire leaving each leg going out to the ground rods?

I've read that copper in contact with zinc (galvanized) is a no-no.
done as suggested by Polyphaser (although not always using their 
products): I've used stainless steel strips (cannibalized from s/s hose 
clamps) between the copper and the zinc. Using bronze clamps.


Alan NV8A


TowerTalk mailing list

Reclaim your name or Get your new email address 
now! Go to

TowerTalk mailing list

<Prev in Thread] Current Thread [Next in Thread>