[Top] [All Lists]

[TowerTalk] R7000 CT1 Trap

To: towertalk <>
Subject: [TowerTalk] R7000 CT1 Trap
From: Michael Tope <>
Date: Mon, 19 Oct 2009 00:10:22 -0700
List-post: <">>
I cleaned out the traps on an old R7000 last weekend. After I got all 
the dead bugs out, the antenna seemed to work fine except for the 12 
meter VSWR dip which is up around 26 MHz. The 10 meter and 15 meter VSWR 
readings are fine which suggests to me that the parallel resonance of 
the 12 meter trap is off (too high). When I had the trap assembly apart, 
the 12 meter coil looked just fine, so there are no obvious physical 
problems with it. Just curious if this is a known problem area? I assume 
adding a more turns to the inductor would do the trick. Assuming 
inductance increases as N^2, then a -1 MHz offset would require an ~2% 
increase in the number of turns. That's pretty small which makes me 
wonder if it isn't the way the last turn is dressed on the coil form on 
the end of the wire that comes up over the lip of trap's outer shell and 
screws to the outside. Maybe I pulled out too much slack on this wire 
when I cleaned out the trap. Anyone had this problem and managed to fix it?

Also, I made need some Cushcraft parts for another R7000 that I am 
cleaning up (this one has a crispy critter CT2 trap which will probably 
need replaced). Anyone tested the waters ordering Cushcraft parts since 
they were sold to MFJ?


Mike W4EF....................


TowerTalk mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [TowerTalk] R7000 CT1 Trap, Michael Tope <=