[Top] [All Lists]

[TowerTalk] U.S. Tower MDP-750 motor failure and related prolems

To: <>
Subject: [TowerTalk] U.S. Tower MDP-750 motor failure and related prolems
From: "Victor Morris" <>
Date: Sun, 19 Dec 2010 17:31:01 -1000
List-post: <">>
Aloha everybody,

I'm new to this group and I'm looking for some help. Earlier this year I 
purchased a TMM-433 HD tower from U.S. Tower. I chose the option with an MDP 
750 motor, inside control box, and outdoor relay box.

Almost from the beginning I've had trouble. It started with what appeared to be 
an intermittent problem with a stuck outdoor relay. Sometimes the tower would 
not raise when e I turned on the power. However if I went outside and tapped 
the box, the tower went up fine. I thought this was just a nuisance, but I may 
have been wrong.

About 3 weeks ago a circuit breaker tripped one time when I tried to lower the 
tower. I reset the breaker and the tower lowered properly.

Then 10 days later I had the same problem except the breaker kept tripping. I 
went outside and found out the motor was extremely hot, and there was a strong 
odor of something burned. Inspection during daylight indicated the starting 
capacitor had blown. Further investigation indicated that a limit switch may 
have vibrated out of position possibly catching on the lowering tower. The 
bracket holding the limit switch was just a bit loose, and I think it could 
have moved. Inside the outdoor relay box a number of screws needed tightening

The tower had to travel 2500 miles by ship to reach Hawaii, and there certainly 
were opportunuties for some items to loosen or shift position.

The problem now is diagnosing and correcting the problem(s). I'm sorry to say 
U.S. Tower customer service has been very minimal to date. It took repeated 
calls and emails to their office to finally contact "Travis". He is the only 
one empowered to make decisions on warranty issues. I was offered the option of 
returning the motor at my expense to US Tower for service. While I plan on 
doing that, I would like to find out what caused my problem in the first place.

Was it just a blown capacitor or "infant mortality" as some say? I do plan on 
ordering new capacitors from a non U.S. Tower source.

Did the outdoor relay box contribute to the issue when the tower failed to rise 
after power was applied? One serious problem here is U.S. Tower provided 
extremely poor overall installation instructions, and no circuit diagrams at 
all for the outdoor relay box and the motor. Does anybody know how to get such 
diagrams? The customer service people have provided no help to date, and I'm 
unable to find any diagrams online.

Could the displaced limit switch have caused or contributed to the problem? 
Does anybody have a photo of an upper limit switch in the correct position? I 
emailed photos to Travis of my upper limit switch, but received no response so 

What would you recommend in my situation? I think replacing the capacitor makes 
sense, but what other checks can I do?  I don't want to hold up shipping the 
motor back to the factory for long, as my warranty expires in late February , 
and I have already received an RMA #. OTOH I don't want to reinstall the motor 
if I still have problems that contributed to the initial motor failure.

Overall I must say I'm disappointed to see an expensive tower have so many 
problems this soon. FYI I'm in a CC&R area and this tower was the only one I 
could get approved after a long battle. And it is the only one that just fits 
in my relatively small 1/4 acre lot in a location well screened by trees.

Any and all good ideas are welcomed!

Vic, AH6WX  

TowerTalk mailing list

<Prev in Thread] Current Thread [Next in Thread>