[Top] [All Lists]

Re: [TowerTalk] troubleshooting help: non-turning G-1000DXA rotor

To: Tower Talk List <>
Subject: Re: [TowerTalk] troubleshooting help: non-turning G-1000DXA rotor
From: Barry N1EU <>
Date: Sun, 2 Sep 2012 16:23:37 +0000
List-post: <">>
I inspected the PSU PCB and see what might be a toasted SM transistor.
 Photo (limited by camera's macro capability):

But still hamstrung without a legible schematic.

Thanks for any comments/advice,
Barry N1EU

On Sun, Sep 2, 2012 at 3:39 PM, Barry N1EU <> wrote:
> The fuse is fine.  There's a faint "burnt" odor inside the controller.
>  Transformer secondary voltages look good.
> 1.  Does anyone have a legible copy of the schematic?  Yaesu's PDF
> version is illegible at the component level.
> 2.  The interconnect diagram clearly shows Q1/D2 connecting to the PSU
> PCB via J1007.  Can someone please point out where the Q1/D2 circuit
> is shown on the schematic diagram?
> Thanks & 73,
> Barry N1EU
> On Sun, Sep 2, 2012 at 1:18 PM, Barry N1EU <> wrote:
>> I'd appreciate any troubleshooting tips for a suddenly non-turning
>> G-1000DXA rotor.  Cable continuity checks good, reading 500 ohms
>> across the pot and 64 ohms across the motor back at the controller
>> connector.  If I hang a voltmeter across the motor pins (4,5) on the
>> back of the controller with cable disconnected, I don't see any
>> voltage generated by the controller when I press the LEFT/RIGHT turn
>> buttons.  Shouldn't I be seeing DC Voltage?  If so, do I next check
>> the fuse on the PS-Unit PCB or ???
>> Any advice appreciated.
>> Tnx/73,
>> Barry N1EU

TowerTalk mailing list

<Prev in Thread] Current Thread [Next in Thread>