[Top] [All Lists]

[Trlog] Kenwood and faster polling

Subject: [Trlog] Kenwood and faster polling
From: Tree <>
Date: Wed, 1 Oct 2003 23:03:57 -0500
List-post: <>
I see that you can now poll the radio more often than once a second.

This has an interesting problem with the Kenwood radios (at least 
my TS850).  If seems that the TS850 can't send serial data to the 
computer while you are turning the VFO knob.  However, it is receiving
the requests for data from the computer and saving them up.  

If you increase the polling frequency (or really its period) to 250 ms,
you will have 4 times the requests saved compared to 1 second polling.

This starts adding up to a lot of data (the Kenwood response is like 
28 bytes in length).  All of the data has to be transferred over the
serial port before the display will update.  

This explains why the frequency display for the Kenwoods could blink
out for awhile - since TR thinks you have disconnected the radio since
it is getting no response.   I have defeated this function for the 
Kenwood - so the old frequency will just stay up there (it is annoying
seeing it blink on and off).  

It appears Ron had set the Kenwood timeout to 1000 ms - in order
to prevent the blink out.  This causes problems if there isn't a
Kenwood hooked up, as the program will spend a whole second waiting
for a response - every 250 milliseconds.  This means it is pretty
much continuously in that loop and not much else gets done.

So - for those of you who have had problems with a Kenwood radio setup
on a port that was off - try reducing your Kenwood Timeout to something
closer to 25 ms.  That should solve the problem.  If you are not happy
with how long it takes the frequency display on the TR screen to update
after turning the VFO knob for about 10 seconds, you might think about
reducing your poll frequency to once per second.  

Trlog mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Trlog] Kenwood and faster polling, Tree <=