[Top] [All Lists]

[WriteLog] Choppy CW Keying Problem

To: <writelog@contesting.com>
Subject: [WriteLog] Choppy CW Keying Problem
From: gregwp@mediaone.net (Greg Papadeas)
Date: Sun, 03 Feb 2002 23:00:11 -0500
I'm having problems getting WriteLog 10.30B to send CW without truncating 1 
out of 3-5 dits or dahs.

My PC configuration is :  P166mmx w/128MB memory running W98SE.  I'm using 
an NPN transistor with the emitter connected to LPT1 pin 1, the base 
connected through a 1K resistor to LPT1 pin 17, and the collector connected 
to the key input of my TS-930S.   Here's what I did to try to isolate the 
problem (without any success):

1. The problem occurs maybe 2 out of every 3 times when sending a "5NN" 
contest exchange repeatedly, for example. I also tried sending the 
character "zero" repeatedly by using the CW keyboard. What I found is that 
in over 95% of the time, one of the five "dahs"  gets truncated to a "dit" 
or shorter. The "dah" that gets truncated appears to always be different, 
i.e. 1st or 2nd or 3rd "dah", etc.

2. I'm able to get perfect CW keying using CT v9.26 running in a DOS window 
(note: not booted up in DOS mode) under W98 with many other programs 
(Windows Explorer, telnet, etc) running on the same machine. Therefore, I 
conclude that the keying interface is probably working ok.

3. I read every note in the WL archives regarding CW keying problems. 
Barry, W2UP reports running a P-60 without any problems, so at least I know 
that the speed of my P-166 should work ok. Another Barry, N1EU, sees the 
same problem on a 550Mhz K6 and 384MB . He suggests that the problem may be 
due to "an internal (asynchronous) Writelog process, rather than an 
external resource limitation (cpu, RAM, etc)".  The fact that CT does not 
show the problem even when running in a DOS window with other programs 
running on the same PC (see #2 above) may support this theory.

4. I deleted all processes except SysTray and Explorer but still see the 

5. I tried renaming winspool.drv (printer spooler) to something else but 
still see the problem.

6. I disconnected my network connection but still see the problem.

7. I inserted the following LPT1 fix in the .ini file without success:

At this point, I'm pretty much out of ideas. Unless I fix this problem 
somehow, WriteLog will be unusable for me in the CW mode. Does anyone have 
other suggestions to fix this problem?

Thanks and 73s,

Greg  KA1O

<Prev in Thread] Current Thread [Next in Thread>