[Top] [All Lists]

[Yaesu] FT-2500M Help Please

To: <yaesu@contesting.com>
Subject: [Yaesu] FT-2500M Help Please
From: dgmaley@soli.inav.net (David G. Maley)
Date: Mon, 10 Sep 2001 16:11:07 -0500 (CDT)
Most modern VHF radios do not use an antenna relay.  PIN diodes do the
switching now.  This doesn't sound like a defective PA module.  I would
look, first, for an intermittant connection.  This could be ata connector,
or cold solder.  Good hunting.

On 10 Sep 2001 k0bx@qsl.net wrote:

> I have a 3 year old FT-2500M.  All has been working until last week.  Let me 
> tell you the problem and see if you might have an opinion of a solution:
> 1.  Receive Ok
> 2.  Transmit - Full output and then NOTHING.  Right in the middle of a 
> sentence, output to zero.
> Then after a minute or two, full output again, may last the whole qso.
> I first thought it might the high SWR on the antenna causing the shutdown.  
> But the antenna checked ok, and I moved the rig in the house and put it on 
> the station antenna and later on a dummy load.  Same problem.  Hi/med/low 
> power setting made no different.
> The 3 things that come to mind that could be the problem are:
> 1.  BAD PA.
> 2.  BAD antenna relay
> 3.  BAD SWR circuit.
>  Anyone have any ideas?  The PA is $90.00.  So Sending it to Yaesu, postage 
> and parts would exceed the cost of a new rig.
> Also if anyone has a circuit diagram that they could send me I would 
> appricate it.
> 73
> Joe K0BX
> k0bx@qsl.net
> http://www.qsl.net/k0bx
> Find the best deals on the web at AltaVista Shopping!
> http://www.shopping.altavista.com
> _______________________________________________
> Yaesu mailing list
> Yaesu@contesting.com
> http://lists.contesting.com/mailman/listinfo/yaesu

<Prev in Thread] Current Thread [Next in Thread>