[Top] [All Lists]

Re: [Yaesu] Yaesu FT767GX Dead

To: Arnie Adelman <arnie.adelman@infosec-consultant.com>, "Ronald Stuy" <pa3ewp@zonnet.nl>,<yaesu@contesting.com>
Subject: Re: [Yaesu] Yaesu FT767GX Dead
From: Peter Sundberg <sm2cew@telia.com>
Date: Tue, 10 Jul 2012 19:58:34 +0000
List-post: <yaesu@contesting.com">mailto:yaesu@contesting.com>
Sounds like the internal PSU is dead. Probably a couple of capacitors in
the switch mode powersupply have gone bad, this is a common fault. Try
running the rig on an external 12 VDC to verify that it is ok. 

Same thing happended to me with my FT-736R. After running it on an external
supply for a while I found a nice 12 volt module that fitted inside the
rig, replacing the original switch mode PSU. 

Hope this helps.

Peter SM2CEW

At 11:45 2012-07-09 , Arnie Adelman wrote:
>All kinds of things happen when you push the FT-767 power button - including 
>meter light, display, cooling fan, etc.  If you're not even getting a meter 
>light, then you're not getting any DC from the built-in power supply. Power 
>cord not fully inserted, fuse, no A/C at the plug or something internal in 
>the power supply.
>----- Original Message ----- 
>From: "Ronald Stuy" <pa3ewp@zonnet.nl>
>To: <yaesu@contesting.com>
>Sent: Sunday, July 08, 2012 1:50 PM
>Subject: [Yaesu] Yaesu FT767GX Dead
>> Hello,
>> A friend of my has a FT767GX for many years. But the last years he hasn't
>> turned it on at all.
>> Last week he tried to power it up again, but nothing.
>> The radio is completely dead, any idea what could be wrong?
>> 73 Ronald
>> _______________________________________________
>> Yaesu mailing list
>> Yaesu@contesting.com
>> http://lists.contesting.com/mailman/listinfo/yaesu
>Yaesu mailing list

Yaesu mailing list

<Prev in Thread] Current Thread [Next in Thread>