[Top] [All Lists]

Re: [Amps] Alpha 87A Problem

To: "'Michael Tope'" <>, <>
Subject: Re: [Amps] Alpha 87A Problem
From: "Dick Green WC1M" <>
Date: Tue, 28 May 2019 19:36:44 -0400
List-post: <>
When AlphaRemote's frequency was jumping all over the place, were you 
transmitting? If so, I'd suspect something wrong with the frequency detector or 
a loose connection or bad component in the RF path to it. If you weren't 
transmitting, then I'd suspect something is going on with the RS-232 interface 
-- maybe noise on it or something. Another possibility is that your computer is 
sending garbage to the amp on the RS232 interface. You could try unplugging the 
RS-232 interface to see if that fixes the problem.

If it doesn't have anything to do with RS-232, then I'd suspect maybe the 
stepper motors aren't moving the tune and/or load caps to the proper positions. 
I've seen that happen a few times. The solution is usually to exercise the caps 
by hitting alternate segment buttons to move them from one end of their travel 
to the other. A few times back and forth usually deals with "sticky" caps.

If that doesn't fix the problem, try returning all segments to factory default. 
See if AlphaMax behaves then. If not, turn off AlphaMax and see if you can 
manually tune a segment for a particular antenna. If that goes OK,  see if the 
tuning is OK after you QSY and come back to that segment. If it's OK, try 
AlphaMax again. If it's not OK, something is going on with the memory or with 
the stepper motors.

Note: a steady carrier helps AlphaMax find the tuning solution better than CW.

Finally, it could be the CPU. Was there any lightning in the area lately? 
Lightning damaged my 87A CPU, though it only killed the TTL pin that connected 
to the RS-232 level converter. Otherwise, the amp worked fine. If a small surge 
hit your amp, maybe it screwed up the serial communications. You can check that 
by connecting with a terminal program and issuing some commands, like SF and HF 
to dump soft and hard faults. If all that looks clean, the RS-232 is probably 

73, Dick WC1M

-----Original Message-----
From: Michael Tope <> 
Sent: Sunday, May 26, 2019 1:55 PM
Subject: [Amps] Alpha 87A Problem

My Alpha 87A had been working  pretty faithfully up until the end of March / 
early April. I haven't used it since then until this weekend. 
Normally I operate remotely, but this weekend I had to come up to my remote 
site for something else, so I decided to play a little bit in the CQ WPX CW 
contest. I noticed right away that the tuning on the 87A seemed squirrely on 40 
meters (the amp kept re-tuning even thought I wasn't changing frequency and 
VSWR appeared stable). When I moved higher in the band to call CQ it seemed to 
settle down and was delivering a steady 1300 watts.

This morning I tried operating 20 meters. At first when I was calling people 
low in the band, the amp seemed okay, but when I went higher in the band, it 
started acting up where it kept hunting for a new tuning solution and in some 
cases it would fault. After a little fiddling, I noticed that the frequency 
readout on the Alpha Remote software was jumping all over the place (in some 
cases up to 16.3 MHz!!). In one case, because of the faulty tuning, I noticed 
that the grid current reading was really high, but the grid trip circuit didn't 
protect the amp.

Any ideas where to start? Seems like it might be a microprocessor problem. When 
it is stable, the amp is making plenty of power (1300 to
1500 watts).

Reducing drive, doesn't seem to help, so I don't think it is an RF in the shack 
problem. I would put it on a dummy load, but my Cantenna is 60 miles away at my 
home QTH (next trip up I will bring it).

73, Mike W4EF...................

Amps mailing list

<Prev in Thread] Current Thread [Next in Thread>