[Top] [All Lists]

[Amps] Acom 2000A controller issue

To: "" <>
Subject: [Amps] Acom 2000A controller issue
From: Eric Dobrowansky <>
Date: Sun, 5 Dec 2021 20:19:43 -0500 (EST)
List-post: <>
I am working on an Acom 2000A with the newer controller (color display).

The amp worked fine the last time it was turned on a few months ago.  Now, when 
the main power switch is turned on, the controller will beep with a steady tone 
for a minute or so, no LCD display shows. Then, after awhile, the display will 
flicker, flash on and off, sometimes white, and the beep will come and go. 
Sometimes, after been left alone for 10 minutes or so, the display start to 
flicker, then eventually stay on, minus the callsign info.  At that time, if I 
press the red power button, the amp will still not turn on.

Would a dead battery on the main unit CPU cause this failure mode?   I seem to 
recall the older style controllers would still power up the amp in this case.   
Is there a battery in this newer style remote control unit? Or does the newer 
style controller act differently than the old controller, in reference to the 
main cpu battery failing?

The way it is acting, it seems to point to the controller, but I'm not sure at 
this point. Especially the way the display flickers for a few minutes when it 
does start to come on. 

Searching the web has not yielded any pertinent information.  Any input would 
be greatly appreciated. I have sent an email to Acom, but figured I would ask 
here on the mailing list as well.


Amps mailing list

<Prev in Thread] Current Thread [Next in Thread>