[CQ-Contest] [Fwd: Re: Any CT DOS Experts out there]

Mark Bailey kd4d at comcast.net
Wed Jun 13 20:55:09 EDT 2007

Hi Dave:

The Byterunner Dual Serial PCI cards allow assigning a different
IRQ to each serial port and I have successfully used them with CT.
(No connection with Byterunner but a satisfied customer).  Their
DOS "driver", VSEMUIO, allows setting the IRQ for each port
separately.  I have not tried the four-port serial cards.

These are the ones I use.  I even take such a card to VY2TT
just for temporary DOS use...



David Pruett wrote:
> -------- Original Message --------
> Subject: 	Re: [CQ-Contest] Any CT DOS Experts out there
> Date: 	Wed, 13 Jun 2007 19:42:27 -0400
> From: 	David Pruett <k8cc at comcast.net>
> To: 	N6KI Dennis Vernacchia <n6ki_73 at sbcglobal.net>
> References: 	<466FB553.3060204 at sbcglobal.net>
> Dennis,
> I have yet to see a PCI dual COM port card be able to use both ports to 
> DOS programs such as CT or NA.  I suspect that this is an IRQ issue.  
> Most of these cards have a single IRQ shared between both ports, but CT 
> (actually its COMTSR driver) and NA are both designed to have separate 
> IRQs for each port.  This cannot be solved in the COMTSR setup; its a 
> function of the hardware design, and hence the driver as well (which 
> does the low level work to make a PCI card look somewhat like an ISA 
> card to the DOS-based program).
> I've never had any issues getting DOS software to interface with a PCI 
> card with a single COM port and the DOS driver.  I have a pair of old 
> Acer Pentium 200 desktops with a built in COM1, a COM2 hooked to a 
> hidden modem interface (which I cannot seem to locate on the 
> motherboard), and a single-COM PCI card as COM3.  COM1 goes to the 
> serial port network, and COM3 to the radio.  Works FB with both CT-DOS 
> and NA.
> One observation (which might not apply to your situation, but is related 
> to the topic) is a problem using IRQ2.  On the PC motherboard, there are 
> one or two IRQ controller chips, each of which control up to 8 different 
> IRQs.  Very old PCs (pre-286) only had one chip, and so could only 
> handle IRQ0 thru IRQ7.  IRQ0 and IRQ1 are used by the operating system 
> itself, while IRQ6 is used by the floppy drive.  With the advent of 
> 80286 and later PCs, a second IRQ controller chip was added, giving 
> eight additional IRQs; IRQ8 thru IRQ15.  According to the documentation 
> I have, IRQ8 is the clock/calendar, IRQ13 is the math co-processor and 
> IRQ14 is the fixed disk drive.
> The problem comes that the output of the second IRQ controller is 
> daisy-chained to the first controller through IRQ2.  Without boring 
> anyone more than necessary, when an IRQ8-IRQ15 occurs, the 2nd chip 
> signals the first through IRQ2 which causes the 1st chip to signal the 
> CPU, and somehow the operating system figures out which IRQ really occurred.
> The reason I bring this up is that I've had ISA COM cards which I've set 
> the dip switches for IRQ2, which could work in one computer, but not in 
> another (both being 80386 or better machines) with my application 
> program (CT or NA) set for IRQ2.  When IRQ2 in the software doesn't 
> work, setting the software for IRQ9 (but the card for IRQ2) usually 
> works.  This appears to be related to how the BIOS maps the IRQs from 
> the 2nd chip, and apparently not all BIOSes work the same.
> I apologize if I've bored anyone with all of this IRQ junk...
> 73,
> Dave/K8CC
> N6KI Dennis Vernacchia wrote:
>> I did post this Query on CT Reflector but thought
>> I'd cover my bases in case someone here knows answer
>> I have a Celeron machine running DOS/WIN98SE
>> I am trying to get CT Ver 10.003 set up for a ham friend
>> Problem is it only has 1 COM port on Mother Board
>> and I need 2, 1 for Telnet Packet ands 1 for Radio Control
>> ( Using Printer Port to key rig for CW - that works fine )
>> I managed to find a NEW 2 COM Port ( 2 DB-9s connectors)
>> PCI board which I installed and the floppy disk that came with it
>> had drivers for DOS and also WIN98
>> I did check the company's web site for any new drivers
>> and the DOS and WIN98 drivers were the same as on the diskette
>> Machine is set to boot into Straight DOS without
>> loading any Windows Driver
>> ( set GUI=0 in System.ini file )
>> That works fine, it boots into DOS on turn on
>> I installed the card and DOS driver and I am able to
>> do a port test with a DOS Utility and both COM ports
>> checkout fine.
>> In the CT Directory I load
>> COMTSR1 ( For my Telnet Packet input and that works fine )
>> I am trying to do radio control for a
>> Kenwood TS-950 on one of the new ports on the
>> Plug in serial card
>> I typed
>> COMTSRX -A2E8 -B4800
>> ( Where X = 2, 3 and 4 com ports.....to no avail)
>> Any ideas what I am doing wrong
>> The Blue confirmation Window always comes up and verifies that
>> I did in fact get the  desired COM port and the port address
>> ( The Serial card booklet instructed me that port addresses
>> are 2E8 and 3E8
>> ( N81 for other defaults as usual )
>> I also went into WIN 98 and loaded those drivers just to be sure
>> WIN98 sees the ports and all is well there but I know not
>> to run CT for DOS in WIN98
>> I do NOT want to run CTWIN if I can help it as have
>> had too many problems in the past with Video chipsets etc
>> not working correct with CTWIN )
>> Ant DOS gurus out there with some other solutions ?
>> 73, Dennis N6KI
>> Sandy Eggo
>> _______________________________________________
>> CQ-Contest mailing list
>> CQ-Contest at contesting.com
>> http://lists.contesting.com/mailman/listinfo/cq-contest
> _______________________________________________
> CQ-Contest mailing list
> CQ-Contest at contesting.com
> http://lists.contesting.com/mailman/listinfo/cq-contest

More information about the CQ-Contest mailing list