[NA-User] LPT1 interface problem on new computer

dap14@daimlerchrysler.com dap14@daimlerchrysler.com
Wed, 19 Jun 2002 16:35:36 -0400


You might take a look at the BIOS settings for the LPT configuration -
specifically, the LPT port may be set up as an EPP (enhanced parallel port)
instead of a SPP (standard parallel port).  (I'm sure about the EPP
designation, I'm not so sure about SPP, but its something like that).

I recently upgraded a computer I use with my music stuff from an old
Socket7 200 MHz Pentium to a new Celeron 900 and motherboard.  The printer
I was using on this machine was my original laser printer - an H/P Laserjet
IIP circa 1991.  (Its so old HP doesn't support it anymore on their driver
web site.)  I could not print successfully until I changed the BIOS setting
from EPP to SPP.

I'm not sure exactly what the differences are between EPP and SPP.  Modern
printers use the LPT port in new, bi-directional ways from the old days,
and its perhaps inevitable that at some point they abandon compatibility
down to the register level which is what NA needs.

Right before WPX CW I had several conversations with an NA user who was
having trouble making his radio talk to the program.  It has worked
successfully with his old Pentium but not with his new high powered
machine.  After a couple of weeks working on it, he called me in a panic
because WPX was only hours away.  I went through the setup with him and he
had everything correct.  Finally, he called the store he bought it from and
they said "Oh yeah, the serial ports on that motherboard are non-standard".
Aaaaaarrrrgggghhhh!  Why do companies do these things?

Responding to Tom Homewood's comment, I doubt the operating system is the
problem.  If it was (as would be the case with Win2000) then the keying
would not work either.  The keying and PTT signals are simply different
bits in the same register - assuming no hardware damage, if one works both
should work.

Steve, let us know if the EPP/SPP thing works out.  Us users of old DOS
programs gotta stick together!



                      Steve Maki                                                                                                   
                      <steve@oakcom.com        To:       na-user@contesting.com                                                    
                      >                        cc:                                                                                 
                      Sent by:                 Subject:  [NA-User] LPT1 interface problem on new computer                          
                      06/19/2002 12:19                                                                                             


Swapped in a new computer, and now I can't key the radio unless I
unplug the PTT line. Problem is the same on several different
(both homemade and commercial) LPT keying interfaces. With the
PTT line hooked to the radio, the PTT works, and the paddle input
works (I hear the computer generated CW), but the radio is not keyed.

With PTT disconnected, radio keys fine. I tried various LPT settings
in the computer's BIOS, but nothing fixes it. Apparently the LPT
pinout on this box is different somehow.

Has anyone run into this?


Steve K8LX
NA-User mailing list