[WriteLog] Enter sends exch/QRZ?

Jerry Pixton jpixton at shentel.net
Sun Aug 24 08:38:58 EDT 2014


Thanks. I reset that param this morning back to 1 and I see that when I 
type a call and press enter the report is sent and the cursor does move 
to the next field. So that solves half the problem.

But when I click on a call in rttyrite window, the cursor moves to the 
next field so that the report never gets sent, just the qrz message!

So the issue is how do I keep the cursor in the call field when I click 
a call into it?

Jerry, W6IHG

On 8/23/2014 9:46 PM, Gary AL9A wrote:
> Jerry,
> In the writelog.ini file [Configuration] section:
> MoveNextOnEnter=1
> 73,
> Gary AL9A
> -----Original Message----- From: Jerry Pixton Sent: August 23, 2014 
> 11:13 AM To: writelog at contesting.com Subject: [WriteLog] Enter sends 
> exch/QRZ?
> Hello all,
> Thinking about my session as w1aw/4. I am checking out the "Enter 
> sends exch/QRZ" function on rtty
> For the life of me, I can not get it to work as described in the help 
> pages. I have tried various times but here is what seems to be happening.
> With esm on and the cursor in the call field with no call, the Enter 
> key sends CQ
> If I type a call in the call field, esm sends the report ok but the 
> cursor stays in the call field.
> I have to space to the next field to get Enter to send the qrz message 
> and log the qso
> Now cursor is back in call field and Enter sends cq again.
> However, if I click on a call in the rttyrite window (or 2tone 
> window), the cursor moves to the next field automatically, so Entry 
> now send the qrz message and logs the qso. The report never gets sent!
> So in either case, typing a call or clicking on a call from rttyrite, 
> the esm behavior seems broken. I suspect there might be one of those 
> hidden ini params that I am missing. I have found "SmartEnterKey" and 
> "MoveNextOnEnter" which do not seem to change the esm behavior.
> I tried this on cw last month and it seemed to work. But of course I 
> was typing a call.
> I see that if I "pop" a call into the call field, instead of clicking 
> from rttyrite, that esm does send the report. But I have to space out 
> of the call field to get the next message.
> The insert, + key work as expected.
> What am I overlooking.
> Jerry, W6IHG

Dr. Jerry R. Pixton, PIXOS Designs
jpixton at shentel.net

More information about the WriteLog mailing list