[ct-user] CTDos crashing after Restarting in DOS Mode

John Bednar k3ct at fast.net
Fri Mar 12 23:06:32 EST 2004

I recently changed my ham radio computer and I immediately learned
that I could no longer start CTDos using the Win98 Start | Shutdown
| "Restart in DOS" option. I have been using CTWin for several years
but it bothered me that I didn't understand what was causing this

In Dos with the above technique, CT it would crash immediately (even
before prompting for the filename). I tried several versions of
CTDos including CT9.27 and CT10.005 with the same results. The panic
crash message from CT9.27 was "Illegal Interrupt #07" along with a
short register dump. CT10.005 display a much larger panic crash
message which included "error(2001) exception 07 device not

As a test, I found that I could successfully start CTDos in a
Windows DOS window but I knew this wasn't recommended so I continued
to experiment.

In steps, I removed all memory except 128M, removed autoexec.bat &
config.sys files, set all BIOS parameters from PCI to ISA, disabled
all caching & shadowing, disabled the USB ports, removed all ISA and
PCI cards except the video card but CT still crashed. I made a
bootable DOS disk from Windows and booted from it, CTDos still

I was ready to give up but I tried one last experiment. I changed
the parameters on the hidden MSDOS.SYS and changed the BOOTGUI line
to BOOTGUI=0. This is documented on the CT Webpage and it prevents
Win98 from booting into the Windows environment from a cold start.
With this change, CTDos finally started without crashing! I tried
several DOS versions and they all started just fine. After replacing
the memory, sound card, network card, 4-port I/O card, and resetting
all the BIOS parameters, CTDos still starts just fine. 

Apparently, Win98 has a set of commands that it runs before
"Restarting in DOS mode". Something that Windows was setting on exit
was causing CTDos to crash. 

k3ct at fast.net

More information about the CT-User mailing list