[TenTec] Eagle com port problems with usb uart

Bob McGraw rmcgraw at blomand.net
Thu Nov 19 21:54:57 EST 2020

The port settings should be 57600, 8 bit, 1 stop, no parity.  You can do 
this from Device Manager.   While monitoring Device Manager, expand the 
COM & LPT ports,  Plug in the USB cable from the Eagle and turn on the 
radio.  The port should automatically open.  If there is a red flag on 
the port line, that says the drivers did not correctly install.   If so, 
then to Advanced for that port and select delete drivers.   Then select 
Update drivers and select from computer.  That should install the 
drivers.  Turn the radio off and then back on.  You should see the port 
go away when you turn the radio off.  And you should see the port be 
re-assigned when you turn the radio on.

If the drivers are not on the computer, then go to the Tentec.COM 
website, to Products, to Transceivers, and to Eagle.  Scroll down to 
documentation and you will find the correct drivers.   Use the procedure 
to copy these from the Tentec site to the computer Desktop.   From there 
using Device Manager you can install the drivers.  From there you will 
need to re-start the computer for the new drivers to take effect.

I've never found that Windows updated or removed or had written over my 

All of this presumes you are NOT using other software such as a logging 
application to control the radio.  And this presumes the radio USB cable 
connects direct from the radio to the computer, no router, no splitter, 
or such.

Having done this many times, it does work reliably.   What I've found 
challenging is the fact there are some 100 different versions {not 
updates} of Windows 10 in English.  It is difficult to "see" your 
computer and your screen and give exact step by step, click by click 
instruction.   I've really found that Windows 10 Pro or 64 bit is quite 
solid and reliable and that updates, which I allow to automatically 
occur, do not cause issues.

You may find better information on Tentec Eagle at Groups.IO in the 
Messages and Files section.   This site is specifically for the Tentec 


Bob, K4TAX

On 11/19/2020 7:48 PM, AA2PM, Paul Mondok wrote:
> Try going into the advanced port settings and adjusting the buffering, etc.  Set things on the slow side.... Also, check set the baud rate, parity & number of stop bits manusly, so that Windows doesn't try the plug & pray thing....
> -------- Original Message --------
> From: Mark killen <markkd8qig at gmail.com>
> Sent: November 19, 2020 7:16:52 PM EST
> To: tentec at contesting.com
> Subject: [TenTec] Eagle com port problems with usb uart
> I'm hoping that someone here can help me.  I'm running windows 10 and
> everytime I try to connect my Eagle to my computer I get a usb problem.  Of
> course I have turned off device signatures, installed the proper driver and
> I still get an error message for the com port.  I've changed the com port
> numbers, I've restarted, uninstalled and reinstalled the Ten Tec Driver,
> and even deleted the driver and let windows pick a driver.  Once in a
> while, it installs correctly but when I turn off the radio and turn it back
> on and I have to go and try everything all over again and hope that
> something works.  But I have tried everything for the past three days and I
> can't get it to work, even temporarily.  Help!  I am going crazy chasing
> this problem down!

This email has been checked for viruses by AVG.

More information about the TenTec mailing list