[TRLog] CW Serial Interface - SOLVED

Ron D. Rossi rrossi@btv.ibm.com
Mon, 22 Jul 2002 11:23:13 -0400


The COM# in windows is just a label and does not always equate the prot 
address you think it does. It is also subject to change if you add or change 
your hardware UNLESS you turn that feature off in the device manager. In 
device manager you will find a place to look at the port memory assignments. 
You may find that windows is using a different address to get at your "COM1". 
You can turn off automatic control. I would give you better directions if I 
were near a Win98 machine, but I am not.

I would suggest trying to find the port windows remapped COM1 to by starting 
the "DOS" window in 98 and then starting with RADIO ONE PORT = 1 in LOGCFG.DAT 
start TR and see if it works. The change to RADIO ONE PORT = 2, etc until it 
works. I bet you find it that way. If you have at this point turned off 
automatic reassigment of ports in device manager you should not have to change 
this in TR again.

73 es God Bless de KK1L...ron rossi(kk1l@arrl.net) <><
Support Programmer for TRLog http://www.qth.com/tr
QTH: Jericho, Vermont
My page: http://www.qsl.net/kk1l

>>>"Sheryl Roux" said:
> First, thanks to all who responded to my request for help.  
> My problem was that the parallel interface keyed the rig but the serial port 
    did not work. All I got at pin 4 of the COM1 port was a constant -11 volts.
     My OS is WIN98 and I have always run TR in a DOS window, which worked fine
     using the LPT port. All I did was restart in "DOS MODE" and run TR from DO
    S. Now both the serial and parallel ports key the rig OK.
> In my case, I guess that with both DOS and Windows running, nothing reached t
    he COM port.
> Thanks again. 73, Jim W4YA
> --- StripMime Report -- processed MIME parts ---
> multipart/alternative
>   text/plain (text body -- kept)
>   text/html
> ---
> _______________________________________________
> TRLog mailing list
> TRLog@contesting.com
> http://lists.contesting.com/mailman/listinfo/trlog