[WriteLog] Parallel Port with V11.06a and XP Pro SP3

Hal Kennedy halken at comcast.net
Wed Nov 21 09:38:07 EST 2012

John brings up an excellent point.  I have had the misfortune of being asked
to troubleshoot both LPT1 and COM port issues at various "mystery" networks
I have encountered on my Dxpedition travels.  I have learned a hard lesson.
The first place I go now is to the bios.  It surprises me how many bios have
either LPT1 set to OFF or one or more COM ports set to OFF.  When any ports
are not working ----- take a look in your bios.


-----Original Message-----
From: WriteLog [mailto:writelog-bounces at contesting.com] On Behalf Of
john at kk9a.com
Sent: Wednesday, November 21, 2012 12:41 AM
To: 'WriteLog'
Subject: Re: [WriteLog] Parallel Port with V11.06a and XP Pro SP3

I received a number or responses to my inquiry which I really appreciate. 
Many gave links to instructions or copied them in the email and some doubted

that I had a 378 address on my PCI card.  I have done this a number of times

with no issues, but it is always possible to forget a step.  I don't believe

that missed anything setting up Direct I/O or Writelog and if I did, I think

Writelog would be been grayed out and not allowed me to select LPT1.  This 
PCI card has programmable DIP switches which I set for 378 and that is the 
range that shows up in the device manager.  I bought this because I was 
unable to get a non standard PCIe card to work on this machine.  I have had 
success with non standard PCI cards on other computers.  What I did notice 
is that there is only one memory range under resources on this computer and 
other computers that I have used with Writelog have a second mapping 
address.  WS7I suggested changing the BIOS to allow ECP+.   This sounded 
like an excellect suggestion. I tired to get this working before the SS 
contest and unfortunately did not see a printer port setting in my BIOS so I

had to manually switch my DX Doubler all weekend.  I'll try again to change 
to a different printer port mode, hopefully it's possible on newer 

----- Original Message ----- 
From: <john at kk9a.com>
To: "'WriteLog'" <writelog at contesting.com>
Sent: Saturday, November 17, 2012 01:55
Subject: Parallel Port with V11.06a and XP Pro SP3

I have a computer that is about a year old with XP Pro SP3 and  I just
installed Writelog  V11.06A.  When I purchased the computer I installed a
SIIG PCIe card with two serial ports and one parallel.  The serial ports
worked fine and I never tried the parallel until this week.  I installed
Direct I/O and checked the appropriate boxes in the ports menu, however the
card just sent a solid CW tone when plugged into a keyer.  Thinking
something was wrong with the card or with using a PCIe slot,  I purchased a
StarTech PCI parallel port adaptor today.  This one was more expensive, but
it uses standard memory mapping.  I installed it and again the devices
manager says that it's working and Writelog recognizes it, but this card
does nothing. I tried reinstalling the driver and used different LPT keyers
and nothing happens.  The checked the mapping of writelog,ini, direct i/o
and the LPT1 device manager and they are all 378.  I have used a parallel
port with an old version of Writelog with XP Pro SP2 for years on many
different cards and computers without issue  Does the newer Writelog and XP
Pro SP3 support a parallel port?   I'm running out of things to try.

John KK9A aka P40A

WriteLog mailing list
WriteLog at contesting.com
WriteLog on the web:  http://www.writelog.com/

More information about the WriteLog mailing list