[Yaesu] FT1000MP problem - Does anyone know what it might be?

Robert Shohet kq2m at earthlink.net
Sun Nov 4 21:33:42 EST 2018

I am trying to diagnose a problem with one of my ‘MP’s......

It ran hot and shut down in CQWWCW last year.  Today it worked fine on 20, but on ALL OTHER BANDS, the receive audio was down 2-3 s-units and the SWR was infinite.  On 20 the SWR was near flat and receive audio was normal.  I repeated this “experiment” several times finally just hooking up one antenna at a time directly to the back of the radio to bypass all other switches, cables, switching devices, etc.  Same result – on 20 it was fine and on all other bands it was down 2-3 s-units and the SWR was infinite.

I then swapped in another ‘MP to the position that the ailing radio had vacated, and the swapped ‘MP worked perfectly.

So it is clearly the ailing radio (and not any other devices) that has an issue or multiple issues.

Has anyone run into this type of problem before?  Does anyone know what could be wrong with my ‘MP?

Please let me know.  Tnx & 73

Bob KQ2M

More information about the Yaesu mailing list